zhanmishu 发表于 2024-8-23 12:18:44

PVE虚拟机内portainer安装qBittorrent

# 环境

基于portainer版本:1.24.2.和docker版本:19.03.5

# 准备几个存储卷

方便qb映射

物理来源pve硬盘,nfs映射

pve上建好目录结构
!(https://roim-picx-bpc.pages.dev/rest/WMuoXHK.png)

创建好存储卷
!(https://roim-picx-bpc.pages.dev/rest/YtepXHK.png)

# Docker部署

步骤可分为①拉取镜像.②映射端口.③映射目录路径.④添加环境变量.以下是每一步的分部教程.以部署qBittorrent举例。(增强版,较多站点不允许)

# 拉取镜像

1. 进入容器,添加容器
   !(https://roim-picx-bpc.pages.dev/rest/sndnXHK.png)
2. 点击高级模式
   !(https://roim-picx-bpc.pages.dev/rest/rcRnXHK.png)
3. 编辑参数
   名称:qbittorrent

镜像源:linuxserver/qbittorrent:latest

添加端口映射:

```
6991-56881 tcp
10010-10010 tcp
6991-56881 udp
```

!(https://roim-picx-bpc.pages.dev/rest/3fgvYHK.png)
备注:这里给出映射参考,添加三个端口映射,两个是数据传输端口(UDP和TCP各一个)和一个WEB UI的访问端口.这里最好把默认的端口都改掉因为6881端口可能会被封(较多站点不允许).8080的WEB UI访问端口可能会引起冲突(因为大把软件会把WEB UI默认设为8080).端口映射可以随便填4-5位数字都可以.只要不是已经被占用了的,随便.

# 添加文件目录路径映射

1. 拉到下面进入存储前,按照下图设置.(前面有添加未使用的存储卷,分别选好)
   !(https://roim-picx-bpc.pages.dev/rest/XXWpXHK.png)
2. 添加环境变量.
   进入环境变量,并添加4个参数.
   WEBUI_PORT #WEB UI的访问端口,在端口映射那里填了什么端口这里就填什么端口.

   PUID #填入自己账户的UID

   PGID #填入自己账户的GID

   TZ #填入linux的时区,在中国一般填写Asia/Shanghai
   !(https://roim-picx-bpc.pages.dev/rest/aFjQXHK.png)
   再修改重启策略为除非停止
   !(https://roim-picx-bpc.pages.dev/rest/MwPQXHK.png)
   部署

临时密码
docker logs -f qbittorrent
!(https://roim-picx-bpc.pages.dev/rest/daBrXHK.png)
查看后登录

# 初始化设置

1. 登录密码
   登录修改
   !(https://roim-picx-bpc.pages.dev/rest/Uc4rXHK.png)
   输入新的密码 滑到最下面点击保存
2. 自动下载设置
   !(https://roim-picx-bpc.pages.dev/rest/cQlWYHK.png)
   保存
3. tracker设置
   来源:https://cf.trackerslist.com/best.txt
   !(https://roim-picx-bpc.pages.dev/rest/YUJWYHK.png)
   保存
4. 链接端口设置
   前面的56881没有生效(**等大佬解答**

面板设置下
!(https://roim-picx-bpc.pages.dev/rest/Tg7wYHK.png)
保存

# 疑难杂症

1. 添加种子,下载几秒钟就报错

点击该种子-Tracker页面,看到

```
DHT/Pex/LSD消息列:这是私有种子

连接pt的是工作的,在pt站点上看也是有连接但是下载速度为0。
```

原因:挂载给pt的存储卷目录没有权限。dht消息仅是提示,不关是可以的(可能站点自动禁止?**等大佬解答**。

因为目录是挂载nfs的,新增目录结构时,使用sudo添加,所有者为root

回到shell修改

```
# sudo chown docker:docker /mnt/nfs/data/qbittorrent/config #部署容器自动修改了目录所有者为docker
sudo chown docker:docker /mnt/nfs/data/qbittorrent/data
sudo chown docker:docker /mnt/nfs/data/qbittorrent/download
sudo chown docker:docker /mnt/nfs/data/qbittorrent/download/incomplete
```

检查权限
!(https://roim-picx-bpc.pages.dev/rest/hSfzYHK.png)

回到面板,继续下载种子,正常了。

2. 下载报错Error: Host not found (non-authoritative), try again later

网传是dns问题。

因为我前面安装docker和拉取镜像时修改了默认网关和dns(31.2)连去旁路网关了。

本来下载也好好的,突然出现这个,换别的种子也是如此,像是拒绝的旁路的网络。

就改回31.1主路由了。重启qb容器ok了。
页: [1]
查看完整版本: PVE虚拟机内portainer安装qBittorrent